Posts Tagged 'Windows OS'

Automatic Updates service fails to start

After I installed Service Pack 2 on my Windows XP workstation, the Automatic Updates service failed to start with the following error:

The Automatic Updates service terminated with the following error:
The class is configured to run as a security id different from the caller.

After some searching online, I found out that this problem is created when certain Administrative security templates are applied to a computer before installing XP SP2. I finally came across the solution here:

http://www.wsuswiki.com/AutomaticUpdatesServiceTerminated

The solution turned out to be a one-line command entered at the command prompt:

SC sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
Here’s the output:
AutomaticUpdates Fix

After I entered it, the AU service started beautifully…

Now I have to figure how to resolve a pesky TFS error message and fix the search index in my SharePoint farm…

Advertisements

RSS Information Week Headlines

  • An error has occurred; the feed is probably down. Try again later.

RSS SharePoint Team Blog

  • An error has occurred; the feed is probably down. Try again later.

RSS InfoPath Team Blog

  • An error has occurred; the feed is probably down. Try again later.

RSS Joel Oleson Blog

  • An error has occurred; the feed is probably down. Try again later.

RSS Susan Hanley’s KM Blog

  • An error has occurred; the feed is probably down. Try again later.

Blog Stats

  • 356,540 hits